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In this lab, we are going to create a data warehouse from the steelwheels database. The data 
warehouse will have a star schema with one fact table and three dimension tables, as shown in the 
following figure: 
 

 
 
The data warehouse will be created as a separate database (called steelwheels_dw) in MySQL. For 
convenience, the SQL instructions needed to create the data warehouse tables are already provided 
in the script steelwheels_dw.sql. 
 

Creating the data warehouse 

 
1. Download the file steelwheels_dw.sql. 
 
2. Take a moment to inspect the contents of the steelwheels_dw.sql script. 

 Locate the CREATE DATABASE statement. 

 Locate all CREATE TABLE statements. 

 Check the columns and data types for each table. 

 Check the primary and foreign keys for each table. 
 
3. Open a terminal and navigate to the folder where the steelwheels_dw.sql script is located. 

 
4. Execute the following command to login to the local MySQL server: mysql -u aid -p 

Password: aid 
 
5. On the MySQL prompt, execute the following command to create the database: 

source steelwheels_dw.sql 
 
6. Execute the following command to show the existing databases: 

show databases; 
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7. Check that you have both the steelwheels database and the steelwheels_dw data warehouse. 
 
8. Leave this terminal open. It will be useful in the next steps. 
 

Creating a connection to the data warehouse 

 
9. Open a new terminal and navigate to the folder: ~/Pentaho/data-integration 
 
10. Start Pentaho Data Integration (PDI) with: ./spoon.sh 
 
11. In the File menu, select New > Transformation. 
 
12. In the left pane, switch from the Design to the View tab, and expand Transformations > 

Transformation 1 > Database connections. 
 
13. Right-click Database connections and select New. 
 
14. In the Database Connection dialog, specify the following: 

 Connection Name: steelwheels_dw 

 Connection Type: MySQL 

 Access:   Native (JDBC) 

 Host Name:  localhost 

 Database Name: steelwheels_dw 

 Port Number:  3306 

 User Name:  aid 

 Password:  aid 
 
15. Press Test to test the database connection. A new dialog should say that the connection is OK. 
 
16. Close the Database Connection dialog with OK. 
 
17. In the View tab, right-click the steelwheels_dw database connection and select Share. This will 

make the database connection available to other transformations. 
 
Note: In the previous lab, you have already created a connection to the steelwheels database. The 
connection to steelwheels_dw is very similar; the only changes are in the Connection Name and in 
the Database Name. In this lab, we will use both connections: steelwheels and steelwheels_dw. 
 

Creating the customer dimension 

 
1. Add a Table Input to the transformation and configure it as follows: 

 In Connection select steelwheels 

 Press the Get SQL select statement button and select the customers table 

 Do you want to include the field-names in the SQL? Answer: Yes 

 Then remove every field except CUSTOMERNUMBER, CUSTOMERNAME, CITY, COUNTRY. 
(See the following figure.) 
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2. Add an Insert/Update step to the transformation, and create a hop from the previous step. 
 

 
 

3. Configure the Insert/Update step as follows: 

 In Connection select steelwheels_dw 

 In Target table click Browse and select the dim_customer table 

 The key that will be used to check if a customer already exists in the dimension table is 
CUSTOMERNUMBER. Therefore, configure The key(s) to look up the value(s) as follows: 

 

 
 

 The dimension table stores the following fields for each customer: CUSTOMERNUMBER, 
CUSTOMERNAME, CITY, COUNTRY. These fields will have to be inserted or updated in the 
table. Therefore, configure Update fields as follows: 

 

 
 
4. Save the transformation as /home/aid/Downloads/dim_customer.ktr (if you are on the VM). 
 
5. Run the transformation. 

 
6. Using the command line, check that the data has been loaded into the dim_customer table in 

the steelwheels_dw data warehouse. 
(See the following figure.) 
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Creating the product dimension 

 
7. Create a new transformation in PDI (Spoon). 
 
8. Add a Table Input to the transformation and configure it as follows: 

 In Connection select steelwheels 

 Press the Get SQL select statement button and select the products table 

 Do you want to include the field-names in the SQL? Answer Yes 

 Then remove every field except PRODUCTCODE, PRODUCTNAME, PRODUCTLINE, 
PRODUCTVENDOR. 

 

 
 
9. Add a Dimension lookup/update, and create a hop from the previous step. 
 

 
 
10. Configure the Dimension lookup/update as follows: 

 In Connection select steelwheels_dw 
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 In Target table click Browse and select the dim_product table 

 The key that will be used to check if a product already exists in the dimension table is 
PRODUCTCODE. Therefore, configure Keys as follows: 

 

 
 

 In addition, the dimension table stores the following fields for each product: 
PRODUCTNAME, PRODUCTLINE, PRODUCTVENDOR. Therefore, configure Fields as follows: 

 

 
 

 Finally, configure the Technical key field, the Version field, the Date range start field, and 
the Table date range end as follows: 

 

 
 

Note: The dim_product dimension table will not use PRODUCTCODE as key. Instead, it will use 
PRODUCT_ID (an integer) as technical/surrogate key. 

 
Note: dim_product is a slowly-changing dimension, meaning that there may be multiple versions 
of the same product, if the information about the product changes over time. 

 
11. Save the transformation as /home/aid/Downloads/dim_product.ktr (if you are on the VM). 
 
12. Run the transformation. 
 
13. Check that the data has been loaded into the dim_product table in the data warehouse. 

(See the following figure.) 
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Testing the slowly-changing dimension 

 
14. In the MySQL prompt, change to the steelwheels database with the command: 

use steelwheels 
 
15. Search for cars with the following query: 

select PRODUCTCODE, PRODUCTNAME, PRODUCTLINE 
from products 
where PRODUCTLINE like '%Cars%' order by PRODUCTNAME; 

 
16. You will see a list of Vintage Cars and Classic Cars. The first Classic Car that appears in this list is a 

Porsche Roadster from 1948 (S18_1889). We will change this product to a Vintage Car. 
 
17. Execute the following query: 

update products set PRODUCTLINE='Vintage Cars' where PRODUCTCODE='S18_1889'; 
 
18. Switch back to PDI (Spoon), and run the dim_product transformation again. 
 
19. Now go back to the MySQL prompt, and change to steelwheels_dw: 

use steelwheels_dw 
 
20. Execute the following query: 

select * from dim_product where PRODUCTCODE='S18_1889'; 
 
21. You will see that there are now two versions of the same product (same PRODUCTCODE, but 

different PRODUCT_ID). In version 1, the Porsche Roadster is listed as a Classic Car, and in 
version 2 it is listed as a Vintage Car. 

 
22. Check the DATE_FROM and DATE_TO fields of the two versions. When did the change from 

version 1 to version 2 occur? At the present time, which version is valid? 
 

Creating the time dimension 

  
23. Create a new transformation in PDI. 
 
24. Add a Table Input to the transformation and configure it as follows: 
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 In Connection select steelwheels 

 Press the Get SQL select statement button and select the orders table 

 Do you want to include the field-names in the SQL? Answer Yes 

 Then remove every field except ORDERDATE. 
 

 
 
25. Add a Calculator step to the transformation, and create a hop from the previous step. 
 

 
 
26. Configure the Calculator as follows: 

 

 
 
27. Add a Value Mapper to the transformation, and create a hop from the previous step. 
 

 
 
28. Configure the Value Mapper as follows: 
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29. Add a second Value Mapper to the transformation and connect it to the previous step. 
 

 
 

30. Configure Value Mapper 2 as follows: 
 

 
 
31. Do a Preview of Value Mapper 2 and check that you have the following results: 
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32. Add an Insert/Update step to the transformation, and create a hop from the previous step. 
 

 
 
33. Configure the Insert/Update step as follows: 

 In Connection select steelwheels_dw 

 In Target table click Browse and select the dim_time table 

 The key that will be used to check if a time already exists in the dimension table is 
ORDERDATE. Therefore, configure The key(s) to look up the value(s) as follows: 

 

 
 

Note: The TIME_ID in the dimension table is mapped to the ORDERDATE stream field. This 
means that a TIME_ID in the data warehouse corresponds to an ORDERDATE in the original 
database. 

 

 The dimension table stores the following fields for each time: TIME_ID, YEAR_ID, QTR_ID, 
QTR_NAME, MONTH_ID, MONTH_NAME. These fields will have to be inserted or updated in 
the table. Therefore, configure Update fields as follows: 

 

 
 
34. Save the transformation as /home/aid/Downloads/dim_time.ktr (if you are on the VM). 
 
35. Run the transformation. 
 
36. Check that the data has been loaded from the orders table in the steelwheels database to the 

dim_time table in the data warehouse. 
(See the following figure.) 
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Creating the fact table 

 
37. Create a new transformation in PDI. 
 
38. Add a Table Input to the transformation and configure it as follows: 

 In Connection select steelwheels 

 In SQL write the following query: 
SELECT * FROM orders NATURAL JOIN orderdetails 

 

 
 
39. Add a Calculator step to the transformation, and create a hop from the previous step. 
 

 
 
40. Configure the Calculator as follows: 
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41. Add a Database lookup step to the transformation, and create a hop from the previous step.  
 

 
 

Note: The purpose of this Database lookup is to get the PRODUCT_ID (the technical/surrogate 
key) for the PRODUCTCODE that comes from the steelwheels database. 

 
42. Configure the Database lookup as follows: 

 In Connection select steelwheels_dw 

 In Lookup table click Browse and select the dim_product table 

 The key that will be used to lookup the product in the dimension table is PRODUCTCODE. 
However, since a product may have multiple versions, we want to retrieve the version that 
was valid at the time when the order was placed. Therefore, configure The key(s) to look up 
the value(s) as follows: 

 

 
 

 The information that we want to retrieve from the dimension table is the PRODUCT_ID (the 
technical/surrogate key). Therefore, configure the Values to return from the lookup table as 
follows: 

 

 
 
43. Do a Preview of the Database lookup in order to check that the PRODUCT_ID is being retrieved. 

(See the following figure.) 
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44. Add an Insert/Update step to the transformation, and create a hop from the previous step.  
 

 
 
45. Configure the Insert/Update step as follows: 

 In Connection select steelwheels_dw 

 In Target table click Browse and select the fact_order table 

 The key that will be used to check if a fact already exists in the fact table is ORDERNUMBER 
and ORDERLINENUMBER. Therefore, configure The key(s) to look up the value(s) as follows: 

 

 
 

 The fact table stores the following fields for each fact: ORDERNUMBER, 
ORDERLINENUMBER, QUANTITYORDERED, PRICEEACH, LINETOTAL, CUSTOMERNUMBER, 
PRODUCT_ID, TIME_ID. These fields will have to be inserted or updated in the table. 
Therefore, configure Update fields as follows: 

 

 
 

Note: The TIME_ID table field is mapped to the ORDERDATE stream field. 
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46. Save the transformation as /home/aid/Downloads/fact_order.ktr (if you are on the VM). 
 
47. Run the transformation. 

 
48. Check that the data has been loaded into the fact_order table in the data warehouse. 
 

 
 
At this point, you have successfully loaded the data into the data warehouse. However, this requires 
running several transformations. We will now create a job to automate this ETL process. 
 

Creating a job 

 
49. Create a new job in PDI (Spoon). 
 
50. In the Design tab, expand General, and drag a START step to the canvas. 
 

 
 
51. Add a Transformation step, and create a hop from the previous step. 
 
52. Configure the Transformation as follows: 

 In Entry Name write dim_customer 

 In Transformation, write /home/aid/Downloads/dim_customer.ktr (if you are on the VM) 
 

 
 
53. Add a new Transformation step, and create a hop from the previous step. 
 
54. Configure the Transformation as follows: 
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 In Entry Name write dim_product 

 In Transformation, write /home/aid/Downloads/dim_product.ktr (if you are on the VM) 
 

 
 
55. Add a new Transformation step, and create a hop from the previous step. 
 
56. Configure the Transformation as follows: 

 In Entry Name write dim_time 

 In Transformation, write /home/aid/Downloads/dim_time.ktr (if you are on the VM) 
 

 
 
57. Add a new Transformation step, and create a hop from the previous step. 
 
58. Configure the Transformation as follows: 

 In Entry Name write fact_order 

 In Transformation, write /home/aid/Downloads/fact_order.ktr (if you are on the VM) 
 

 
 
59. Save the job as /home/aid/Downloads/load_dw.kjb (if you are on the VM) 
 
60. Run the job.  

Note: The job runs a sequence of transformations. Each transformation runs upon successful 
completion of the previous one. You can run this job whenever you need to reload or update the 
data warehouse. 

 
61. Take a screenshot of PDI showing that the complete job has run successfully. 


